ZendFramework potential Cross-site Scripting vectors due to inconsistent encodings
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.9.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- >= 1.9.0, < 1.9.7
- Fixed in
- 1.9.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg35-vqp3-fv39 lists affected ranges: Packagist zendframework/zendframework1 >=1.9.0 <1.9.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A number of classes, primarily within the ZendForm, ZendFilter, ZendForm, ZendLog and ZendView components, contained character encoding inconsistencies whereby calls to the htmlspecialchars() and htmlentities() functions used undefined or hard coded charset parameters. In many of these cases developers were unable to set a character encoding of their choice. These inconsistencies could, in specific circumstances, allow certain multibyte representations of special HTML characters pass through unescaped leaving applications potentially vulnerable to cross-site scripting (XSS) exploits. Such exploits would only be possible if a developer used a non-typical character encoding (such as UTF-7), allowed users to define the character encoding, or served HTML documents without a valid character set defined.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hg35-vqp3-fv39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hg35-vqp3-fv39 Advisory: ZendFramework potential Cross-site Scripting vectors due to inconsistent encodings IDs: GHSA-hg35-vqp3-fv39 Record: https://patchnext.com/advisories/ghsa-hg35-vqp3-fv39 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.9.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected >= 1.9.0, < 1.9.7; fixed in 1.9.7 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hg35-vqp3-fv39 (GitHub-reviewed advisory GHSA-hg35-vqp3-fv39 lists affected ranges: Packagist zendframework/zendframework1 >=1.9.0 <1.9.7) Commands are suggestions: review each one before running it.
Loading voting…