Uptime Kuma Authenticated remote code execution via TailscalePing
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 1.23.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm uptime-kuma
- Affected
- >= 1.23.0, <= 1.23.6
- Fixed in
- 1.23.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hfxh-rjv7-2369 lists affected ranges: npm uptime-kuma >=1.23.0 <1.23.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfxh-rjv7-2369 lists affected ranges: npm uptime-kuma >=1.23.0 <=1.23.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The runTailscalePing method of the TailscalePing class injects the hostname parameter inside a shell command, leading to a command injection and the possibility to run arbitrary commands on the server. Details When adding a new monitor on Uptime Kuma, we can select the "Tailscale Ping" type. Then we can add a hostname and insert a command injection payload into it. The front-end application requires that the field follow a specific pattern, this validation only happens on the front-end and can be removed by removing the attribute pattern on the input element. https://github.com/louislam/uptime-kuma/blob/dc4242019331e65a79ac16deef97510144e01b12/server/monitor-types/tailscale-ping.js#L40-L46 We can finally add the new monitor and observe that our command is being executed. NOTE: When using Uptime Kuma inside a container, the "TailScale Ping" type is not visible. We can fake this information by intercepting WebSocket messages and set the isContainer option to false. PoC…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hfxh-rjv7-2369
- Revision 1 · created ·
Published from osv record GHSA-hfxh-rjv7-2369
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hfxh-rjv7-2369 Advisory: Uptime Kuma Authenticated remote code execution via TailscalePing IDs: GHSA-hfxh-rjv7-2369 Record: https://patchnext.com/advisories/ghsa-hfxh-rjv7-2369 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 1.23.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm uptime-kuma: affected >= 1.23.0, <= 1.23.6; fixed in 1.23.7 ## Suggested inspection (read-only) - `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uptime-kuma. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hfxh-rjv7-2369 (OSV record GHSA-hfxh-rjv7-2369 lists affected ranges: npm uptime-kuma >=1.23.0 <1.23.7 (fixed)) - Verified: https://github.com/advisories/GHSA-hfxh-rjv7-2369 (GitHub-reviewed advisory GHSA-hfxh-rjv7-2369 lists affected ranges: npm uptime-kuma >=1.23.0 <=1.23.6) Commands are suggestions: review each one before running it.
Loading voting…