Vulnerability allowing for reading internal HTTP resources
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts-export-server 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.0.30
- Fixed in
- 2.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hfwx-c7q6-g54c lists affected ranges: npm highcharts-export-server >=0 <2.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfwx-c7q6-g54c lists affected ranges: npm highcharts-export-server >=0 <=2.0.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability allows for reading and outputting files served by other services on the internal network in which the export server is hosted. If the export server is exposed to the internet, this potentially allows a malicious user to gain read access to internal web-resources. The impact is limited to internal services that serve content via. HTTP(S), and requires the attacker to know internal hostnames/IP addresses. The previous versions have been marked as deprecated on NPM. Patches Version 2.1.0 released alongside this security advisory addresses the issue. Please note that this release is not backwards compatible out of the box. See the changelog for details. Additionally, it's also recommended to upgrade to the latest version of Highcharts to get the added input sanitation implemented in version 9.0 and later. Workarounds There are no known workarounds to the issue - an upgrade to version 2.1.0 is required. For more information If you have any questions or comments…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hfwx-c7q6-g54c
- Revision 1 · created ·
Published from osv record GHSA-hfwx-c7q6-g54c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hfwx-c7q6-g54c Advisory: Vulnerability allowing for reading internal HTTP resources IDs: GHSA-hfwx-c7q6-g54c Record: https://patchnext.com/advisories/ghsa-hfwx-c7q6-g54c (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: highcharts-export-server 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm highcharts-export-server: affected <= 2.0.30; fixed in 2.1.0 ## Suggested inspection (read-only) - `npm ls highcharts-export-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on highcharts-export-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hfwx-c7q6-g54c (OSV record GHSA-hfwx-c7q6-g54c lists affected ranges: npm highcharts-export-server >=0 <2.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hfwx-c7q6-g54c (GitHub-reviewed advisory GHSA-hfwx-c7q6-g54c lists affected ranges: npm highcharts-export-server >=0 <=2.0.30) Commands are suggestions: review each one before running it.
Loading voting…