AWS-LC has PKCS7_verify Signature Validation Bypass
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-lc-sys 0.38.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io aws-lc-sys
- Affected
- >= 0.24.0, < 0.38.0
- Fixed in
- 0.38.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfpc-8r3f-gw53 lists affected ranges: crates.io aws-lc-sys >=0.24.0 <0.38.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary AWS-LC is an open-source, general-purpose cryptographic library. Impact Improper signature validation in PKCS7verify() in AWS-LC allows an unauthenticated user to bypass signature verification when processing PKCS7 objects with Authenticated Attributes. Customers of AWS services do not need to take action. aws-lc-sys contains code from AWS-LC. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys. Impacted versions: aws-lc-sys versions: = 0.24.0, < 0.38.0 Patches The patch is included in v0.38.0 Workarounds There is no workaround. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys. Resources If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via the vulnerability reporting page or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hfpc-8r3f-gw53
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hfpc-8r3f-gw53 Advisory: AWS-LC has PKCS7_verify Signature Validation Bypass IDs: GHSA-hfpc-8r3f-gw53 Record: https://patchnext.com/advisories/ghsa-hfpc-8r3f-gw53 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aws-lc-sys 0.38.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io aws-lc-sys: affected >= 0.24.0, < 0.38.0; fixed in 0.38.0 ## Suggested inspection (read-only) - crates.io aws-lc-sys: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aws-lc-sys. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hfpc-8r3f-gw53 (GitHub-reviewed advisory GHSA-hfpc-8r3f-gw53 lists affected ranges: crates.io aws-lc-sys >=0.24.0 <0.38.0) Commands are suggestions: review each one before running it.
Loading voting…