Skip to content

← Actionable
Critical, CVSS 9.8amended

imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution

GHSA-hff9-5pqw-6w9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/imgproxy/imgproxy 4.0.16; github.com/imgproxy/imgproxy/v2 4.0.16; github.com/imgproxy/imgproxy/v3 4.0.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The ICO loader allocates `data_size + BMP_FILE_HEADER_LEN` bytes after reading a 32-bit attacker-controlled `data_size`. For `data_size > UINT32_MAX - BMP_FILE_HEADER_LEN`, the addition wraps before allocation. imgproxy then writes the ICO prefix and reads up to the original declared size starting 14 bytes into the undersized allocation. A network client can turn this heap overflow into remote denial of service or remote code execution.

Technical details The vulnerable path is in `vips/icoload.c` at commit `f4fedbb`: ```c uint32_t data_size = GUINT32_FROM_LE(largest_image_header.data_size); VipsPel *data = (VipsPel *) VIPS_MALLOC(NULL, data_size + BMP_FILE_HEADER_LEN); void *actual_data = data + BMP_FILE_HEADER_LEN; if (vips_foreign_load_read_full(ico->source, actual_data, data_size) <= 0) { vips_error("vips_foreign_load_ico_header", "unable to read ICO image…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-hff9-5pqw-6w9f

  2. Revision 1 · created ·

    Published from ghsa record GHSA-hff9-5pqw-6w9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hff9-5pqw-6w9f

Advisory: imgproxy has integer overflow in imgproxy ICO loader that causes denial of service and may permit remote code execution
IDs: GHSA-hff9-5pqw-6w9f
Record: https://patchnext.com/advisories/ghsa-hff9-5pqw-6w9f (revision 2, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/imgproxy/imgproxy 4.0.16; github.com/imgproxy/imgproxy/v2 4.0.16; github.com/imgproxy/imgproxy/v3 4.0.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/imgproxy/imgproxy: affected >= 4.0.0, < 4.0.16; fixed in 4.0.16
- Go github.com/imgproxy/imgproxy/v2: affected >= 4.0.0, < 4.0.16; fixed in 4.0.16
- Go github.com/imgproxy/imgproxy/v3: affected >= 4.0.0, < 4.0.16; fixed in 4.0.16

## Suggested inspection (read-only)
- Go github.com/imgproxy/imgproxy: check the installed version with your package manager.
- Go github.com/imgproxy/imgproxy/v2: check the installed version with your package manager.
- Go github.com/imgproxy/imgproxy/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2, github.com/imgproxy/imgproxy/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hff9-5pqw-6w9f (GitHub-reviewed advisory GHSA-hff9-5pqw-6w9f lists affected ranges: Go github.com/imgproxy/imgproxy/v3 >=4.0.0 =4.0.0 =4.0.0 <4.0.16)
- Verified: https://osv.dev/vulnerability/GHSA-hff9-5pqw-6w9f (OSV record GHSA-hff9-5pqw-6w9f lists affected ranges: Go github.com/imgproxy/imgproxy/v3 >=4.0.0 =4.0.0 =4.0.0 <4.0.16 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…