Skip to content

← Actionable
High, CVSS 8.2

libcrux: Potential Panic on Overlong Ciphertext Buffer

GHSA-hc3c-63hc-2r9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (libcrux-chacha20poly1305 0.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

An application that passes in a ciphertext buffer of length greater than ptxt.len() + TAGLEN to libcruxchacha20poly1305::encrypt or libcruxchacha20poly1305::xchacha20poly1305::encrypt would experience a panic. Impact An application where the length of the ciphertext buffer is under attacker control could be made to crash. Mitigation The fix makes it so that libcruxchacha20poly1305::encrypt and libcruxchacha20poly1305::xchacha20poly1305::encrypt no longer panic in this case, but instead write out the ciphertext and tag into the first ptxt.len() + TAGLEN bytes of the provided buffer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hc3c-63hc-2r9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hc3c-63hc-2r9f

Advisory: libcrux: Potential Panic on Overlong Ciphertext Buffer
IDs: GHSA-hc3c-63hc-2r9f
Record: https://patchnext.com/advisories/ghsa-hc3c-63hc-2r9f (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: libcrux-chacha20poly1305 0.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io libcrux-chacha20poly1305: affected < 0.0.8; fixed in 0.0.8

## Suggested inspection (read-only)
- crates.io libcrux-chacha20poly1305: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on libcrux-chacha20poly1305.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hc3c-63hc-2r9f (GitHub-reviewed advisory GHSA-hc3c-63hc-2r9f lists affected ranges: crates.io libcrux-chacha20poly1305 >=0 <0.0.8)

Commands are suggestions: review each one before running it.

Loading voting…