Regex denial of service vulnerability in codesample plugin
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 5.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tinymce
- Affected
- < 5.6.0
- Fixed in
- 5.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h96f-fc7c-9r55 lists affected ranges: npm tinymce >=0 <5.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h96f-fc7c-9r55 lists affected ranges: npm tinymce >=0 <5.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A regex denial of service (ReDoS) vulnerability was discovered in a dependency of the codesample plugin. The vulnerability allowed poorly formed ruby code samples to lock up the browser while performing syntax highlighting. This impacts users of the codesample plugin using TinyMCE 5.5.1 or lower. Patches This vulnerability has been patched in TinyMCE 5.6.0 by upgrading to a version of the dependency without the vulnerability. Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.6.0 or higher - Disable the codesample plugin - Disable ruby code samples using the codesamplelanguages setting - Override the PrismJS syntax highlighter to version 1.21.0 or higher using the codesampleglobalprismjs setting Acknowledgements Tiny Technologies would like to thank Erik Krogh Kristensen at GitHub for discovering this vulnerability. References https://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes For more information If you have any questions or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h96f-fc7c-9r55
- Revision 1 · created ·
Published from osv record GHSA-h96f-fc7c-9r55
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-h96f-fc7c-9r55 Advisory: Regex denial of service vulnerability in codesample plugin IDs: GHSA-h96f-fc7c-9r55 Record: https://patchnext.com/advisories/ghsa-h96f-fc7c-9r55 (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 5.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tinymce: affected < 5.6.0; fixed in 5.6.0 ## Suggested inspection (read-only) - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h96f-fc7c-9r55 (OSV record GHSA-h96f-fc7c-9r55 lists affected ranges: npm tinymce >=0 <5.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h96f-fc7c-9r55 (GitHub-reviewed advisory GHSA-h96f-fc7c-9r55 lists affected ranges: npm tinymce >=0 <5.6.0) Commands are suggestions: review each one before running it.
Loading voting…