Echo: Decompress permits unbounded gzip expansion in v4
CVE-2026-118261GHSA-h7wr-284f-5qvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/labstack/echo/v4 4.16.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/labstack/echo/v4
- Affected
- >= 4.0.0, < 4.16.1
- Fixed in
- 4.16.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h7wr-284f-5qvc lists affected ranges: Go github.com/labstack/echo/v4 >=4.0.0 <4.16.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h7wr-284f-5qvc lists affected ranges: Go github.com/labstack/echo/v4 >=4.0.0 <4.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-118261: 0.37% estimated exploitation activity in the next 30 days; percentile 31.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Echo v4's opt-in Decompress middleware exposed a gzip-decoded request stream without limiting its expanded size. A small compressed request could therefore produce a very large decoded body. Handlers that read or bind that body could consume excessive memory or CPU, and repeated or concurrent requests could cause denial of service. The middleware is not enabled by default. A limit on the compressed request size alone does not bound the decompressed size. Applications that already apply an effective body limit after decompression have reduced exposure.
Affected versions and patch Echo v4 versions through v4.16.0 are affected. Upgrade to v4.16.1. The patch adds `DecompressConfig.MaxDecompressedSize`, defaulting to 100 MiB when zero. A value of `-1` explicitly disables the limit. Reading beyond the cap returns `ErrStatusRequestEntityTooLarge` (HTTP 413), including through JSON and XML binding. Bodies exactly at the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 6 · amended ·
Amended from osv record GHSA-h7wr-284f-5qvc
- Revision 5 · amended ·
Amended from ghsa record GHSA-h7wr-284f-5qvc
- Revision 4 · amended ·
Amended from ghsa record GHSA-h7wr-284f-5qvc
- Revision 3 · amended ·
Amended from ghsa record GHSA-h7wr-284f-5qvc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h7wr-284f-5qvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-118261 Advisory: Echo: Decompress permits unbounded gzip expansion in v4 IDs: CVE-2026-118261, GHSA-h7wr-284f-5qvc Record: https://patchnext.com/advisories/ghsa-h7wr-284f-5qvc (revision 6, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/labstack/echo/v4 4.16.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/labstack/echo/v4: affected >= 4.0.0, < 4.16.1; fixed in 4.16.1 ## Suggested inspection (read-only) - Go github.com/labstack/echo/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/labstack/echo/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h7wr-284f-5qvc (OSV record GHSA-h7wr-284f-5qvc lists affected ranges: Go github.com/labstack/echo/v4 >=4.0.0 <4.16.1 (fixed)) - Verified: https://github.com/advisories/GHSA-h7wr-284f-5qvc (GitHub-reviewed advisory GHSA-h7wr-284f-5qvc lists affected ranges: Go github.com/labstack/echo/v4 >=4.0.0 <4.16.1) Commands are suggestions: review each one before running it.
Loading voting…