Poweradmin: API user-update endpoint leads to a non-admin reset any user's password and take over the superuser account
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (poweradmin/poweradmin 4.3.4, 4.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist poweradmin/poweradmin
- Affected
- >= 4.0.0, < 4.2.5>= 4.3.0, < 4.3.4
- Fixed in
- 4.3.4, 4.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4hf-v6w5-897x lists affected ranges: Packagist poweradmin/poweradmin >=4.0.0 =4.3.0 <4.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The REST API user-update endpoint (PUT/PATCH /api/v2/users/{id} and the V1 equivalent) does not enforce two authorization rules that the web interface enforces. A user who holds the usereditothers permission but is not a superuser can: 1. edit user accounts that belong to a superuser, and 2. set the password of any account, even without the userpasswdeditothers permission. Because of this, a non-admin "user manager" role can send a single API request that changes the administrator's password, then log in as the administrator. This is a full privilege escalation and account takeover. The same actions are explicitly blocked in the web UI, so the API is inconsistent with the application's own permission model. Details Poweradmin's permission model treats these as three distinct permissions: - usereditothers (id 57): "User is allowed to edit other users." - userpasswdeditothers (id 58): "User is allowed to edit the password of other users." - userisueberuser (id 53): full admin.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4hf-v6w5-897x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-h4hf-v6w5-897x Advisory: Poweradmin: API user-update endpoint leads to a non-admin reset any user's password and take over the superuser account IDs: GHSA-h4hf-v6w5-897x Record: https://patchnext.com/advisories/ghsa-h4hf-v6w5-897x (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: poweradmin/poweradmin 4.3.4, 4.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist poweradmin/poweradmin: affected >= 4.0.0, < 4.2.5; >= 4.3.0, < 4.3.4; fixed in 4.3.4, 4.2.5 ## Suggested inspection (read-only) - Packagist poweradmin/poweradmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on poweradmin/poweradmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4hf-v6w5-897x (GitHub-reviewed advisory GHSA-h4hf-v6w5-897x lists affected ranges: Packagist poweradmin/poweradmin >=4.0.0 =4.3.0 <4.3.4) Commands are suggestions: review each one before running it.
Loading voting…