Clauster: Non-loopback deployments can serve the dashboard unauthenticated when auth.enabled is unset
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (clauster 0.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI clauster
- Affected
- <= 0.2.1
- Fixed in
- 0.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h4g2-xfmw-q2c9 lists affected ranges: PyPI clauster >=0 <0.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4g2-xfmw-q2c9 lists affected ranges: PyPI clauster >=0 <=0.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A Clauster instance bound to a non-loopback address (e.g. 0.0.0.0 or a LAN IP) can serve the entire dashboard and its API without any authentication — even when the operator has configured a password — if auth.enabled is left at its default (false). The operator believes the instance is password-protected; in reality every request is served unauthenticated. Impact An unauthenticated attacker with network access to the instance gains full control of the dashboard: list projects, spawn/stop claude remote-control bridges in any project directory, edit CLAUDE.md, read bridge logs, and (where configured) clone repositories. Because bridges run Claude Code against the host's project directories, this is effectively remote code execution in those projects. Loopback (127.0.0.1) deployments need no auth by design and are not affected. Affected configurations All released versions (≤ 0.2.1) where all of the following hold: - host is a non-loopback address, and - auth.passwordrequired:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h4g2-xfmw-q2c9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h4g2-xfmw-q2c9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-h4g2-xfmw-q2c9 Advisory: Clauster: Non-loopback deployments can serve the dashboard unauthenticated when auth.enabled is unset IDs: GHSA-h4g2-xfmw-q2c9 Record: https://patchnext.com/advisories/ghsa-h4g2-xfmw-q2c9 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: clauster 0.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI clauster: affected <= 0.2.1; fixed in 0.2.2 ## Suggested inspection (read-only) - `python -m pip show clauster`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on clauster. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h4g2-xfmw-q2c9 (OSV record GHSA-h4g2-xfmw-q2c9 lists affected ranges: PyPI clauster >=0 <0.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-h4g2-xfmw-q2c9 (GitHub-reviewed advisory GHSA-h4g2-xfmw-q2c9 lists affected ranges: PyPI clauster >=0 <=0.2.1) Commands are suggestions: review each one before running it.
Loading voting…