Webauthn has a User Verification Downgrade via Default-Open ClientOverridePolicy
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-auth/webauthn-framework 5.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist web-auth/webauthn-framework
- Affected
- >= 5.3.0, < 5.3.1
- Fixed in
- 5.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4fw-6r7f-w494 lists affected ranges: Packagist web-auth/webauthn-framework >=5.3.0 <5.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.1 · CVSS:3.1/AV:P/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary In version 5.3.0 of the Symfony bundle, Webauthn\Bundle\Policy\ClientOverridePolicy defaulted to allowing all client overrides, including userVerification. A client could send {"userVerification": "discouraged"} in the assertion or attestation options request to override a server-configured userVerification: required, causing the emitted WebAuthn options to instruct the authenticator to skip user verification. The CheckUserVerification ceremony step then read the same downgraded options and skipped its check. Affected versions - Vulnerable: 5.3.0 - Patched: 5.3.1 5.3.0 was released on 2026-05-01 and 5.3.1 was published roughly 18 hours later, on 2026-05-02. Practical exposure window was minimal. Note on earlier 5.x versions Versions 5.0.0 to 5.2.x did not ship ClientOverridePolicy (introduced in 5.3.0), so the exact code path described above does not apply. However, on those versions the ProfileBasedRequestOptionsBuilder and ProfileBasedCreationOptionsBuilder already passed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4fw-6r7f-w494
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-h4fw-6r7f-w494 Advisory: Webauthn has a User Verification Downgrade via Default-Open ClientOverridePolicy IDs: GHSA-h4fw-6r7f-w494 Record: https://patchnext.com/advisories/ghsa-h4fw-6r7f-w494 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-auth/webauthn-framework 5.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist web-auth/webauthn-framework: affected >= 5.3.0, < 5.3.1; fixed in 5.3.1 ## Suggested inspection (read-only) - Packagist web-auth/webauthn-framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-auth/webauthn-framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4fw-6r7f-w494 (GitHub-reviewed advisory GHSA-h4fw-6r7f-w494 lists affected ranges: Packagist web-auth/webauthn-framework >=5.3.0 <5.3.1) Commands are suggestions: review each one before running it.
Loading voting…