Skip to content

← Actionable
Critical, CVSS 9.1amended

openssl-encrypt: TOTP rate limiter is in-memory only — not shared across workers, lost on restart

CVE-2026-74878GHSA-h45m-mgcp-q388

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-encrypt 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-74878: 0.75% estimated exploitation activity in the next 30 days; percentile 54.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Severity: HIGH Summary The TOTP brute-force rate limiter in opensslencryptserver/modules/pepper/totp.py at lines 47-98 uses an in-memory defaultdict(list) as a class variable. Affected Code Impact 1. Rate limit state is not shared across multiple server instances/workers — an attacker can distribute attempts 2. All rate limit state is lost on server restart — allows immediate retry 3. In multi-worker deployments, each worker has independent rate limit state Recommended Fix - Use Redis or the database for rate limit state storage - Or use a shared-memory approach for multi-worker deployments - At minimum, persist lockout state to survive restarts Fix Fixed in commit 2749bc0 on branch releases/1.4.x — added abstract RateLimitBackend with InMemoryBackend and DatabaseBackend implementations; defaults to DatabaseBackend when DB available.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-h45m-mgcp-q388

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-h45m-mgcp-q388

  4. Revision 1 · created ·

    Published from ghsa record GHSA-h45m-mgcp-q388

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-74878

Advisory: openssl-encrypt: TOTP rate limiter is in-memory only — not shared across workers, lost on restart
IDs: CVE-2026-74878, GHSA-h45m-mgcp-q388
Record: https://patchnext.com/advisories/ghsa-h45m-mgcp-q388 (revision 4, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-encrypt 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openssl-encrypt: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `python -m pip show openssl-encrypt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-encrypt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h45m-mgcp-q388 (GitHub-reviewed advisory GHSA-h45m-mgcp-q388 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-h45m-mgcp-q388 (OSV record GHSA-h45m-mgcp-q388 lists affected ranges: PyPI openssl-encrypt >=0 <1.4.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…