@envelop/graphql-modules has a Race Condition vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@envelop/graphql-modules 9.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 9.1.0
- Fixed in
- 9.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h3hw-29fv-2x75 lists affected ranges: npm @envelop/graphql-modules >=0 <9.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h3hw-29fv-2x75 lists affected ranges: npm @envelop/graphql-modules >=0 <9.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Context race condition when using useGraphQLModules plugin Details Related to: https://github.com/graphql-hive/graphql-modules/security/advisories/GHSA-53wg-r69p-v3r7 When 2 or more parallel requests are made which trigger the same service, the context of the requests is mixed up in the service when the context is injected via @ExecutionContext() and graphql-modules are used in Yoga with useGraphQLModules(application). This issue was fixed in graphql-modules in 2.4.1 and 3.1.1 but using useGraphQLModules will bypass the asynchooks fix that was implemented. PoC Create the following package.json and run npm i Define the app entrypoint: src/index.ts Create the test module: src/module.ts Add the Service that's to be injected src/service.ts Add the test case test/bleedtest.js Then run the server with npm run start in one terminal and the testcase in another with npm run test. The returned IDs should be identical as they are both read from the context within the same request.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h3hw-29fv-2x75
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h3hw-29fv-2x75
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-h3hw-29fv-2x75 Advisory: @envelop/graphql-modules has a Race Condition vulnerability IDs: GHSA-h3hw-29fv-2x75 Record: https://patchnext.com/advisories/ghsa-h3hw-29fv-2x75 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @envelop/graphql-modules 9.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @envelop/graphql-modules: affected < 9.1.0; fixed in 9.1.0 ## Suggested inspection (read-only) - `npm ls @envelop/graphql-modules --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @envelop/graphql-modules. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h3hw-29fv-2x75 (OSV record GHSA-h3hw-29fv-2x75 lists affected ranges: npm @envelop/graphql-modules >=0 <9.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h3hw-29fv-2x75 (GitHub-reviewed advisory GHSA-h3hw-29fv-2x75 lists affected ranges: npm @envelop/graphql-modules >=0 <9.1.0) Commands are suggestions: review each one before running it.
Loading voting…