Skip to content

← Actionable
High, CVSS 7.5amended

Next.js HTTP request deserialization can lead to DoS when using insecure React Server Components

GHSA-h25m-26qc-wcjf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.5, 16.0.11, 15.6.0-canary.61, 15.5.10, 15.4.11, 15.3.9, 15.2.9, 15.1.12, 15.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 13.0.0, < 15.0.8>= 15.1.1-canary.0, < 15.1.12>= 15.2.0-canary.0, < 15.2.9>= 15.3.0-canary.0, < 15.3.9>= 15.4.0-canary.0, < 15.4.11>= 15.5.1-canary.0, < 15.5.10>= 15.6.0-canary.0, < 15.6.0-canary.61>= 16.0.0-beta.0, < 16.0.11>= 16.1.0-canary.0, < 16.1.5
    Fixed in
    15.5.10, 16.1.5, 15.0.8, 15.1.12, 15.2.9, 16.0.11, 15.4.11, 15.6.0-canary.61, 15.3.9

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-h25m-26qc-wcjf lists affected ranges: npm next >=13.0.0 =15.1.1-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.1-canary.0 =15.6.0-canary.0 =16.0.0-beta.0 =16.1.0-canary.0 <16.1.5 (fixed)

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-h25m-26qc-wcjf lists affected ranges: npm next >=13.0.0 =15.1.1-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.1-canary.0 =15.6.0-canary.0 =16.0.0-beta.0 =16.1.0-canary.0 <16.1.5

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as CVE-2026-23864. A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h25m-26qc-wcjf

  2. Revision 1 · created ·

    Published from osv record GHSA-h25m-26qc-wcjf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-h25m-26qc-wcjf

Advisory: Next.js HTTP request deserialization can lead to DoS when using insecure React Server Components
IDs: GHSA-h25m-26qc-wcjf
Record: https://patchnext.com/advisories/ghsa-h25m-26qc-wcjf (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.1.5, 16.0.11, 15.6.0-canary.61, 15.5.10, 15.4.11, 15.3.9, 15.2.9, 15.1.12, 15.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 13.0.0, < 15.0.8; >= 15.1.1-canary.0, < 15.1.12; >= 15.2.0-canary.0, < 15.2.9; >= 15.3.0-canary.0, < 15.3.9; >= 15.4.0-canary.0, < 15.4.11; >= 15.5.1-canary.0, < 15.5.10; >= 15.6.0-canary.0, < 15.6.0-canary.61; >= 16.0.0-beta.0, < 16.0.11; >= 16.1.0-canary.0, < 16.1.5; fixed in 15.5.10, 16.1.5, 15.0.8, 15.1.12, 15.2.9, 16.0.11, 15.4.11, 15.6.0-canary.61, 15.3.9

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h25m-26qc-wcjf (OSV record GHSA-h25m-26qc-wcjf lists affected ranges: npm next >=13.0.0 =15.1.1-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.1-canary.0 =15.6.0-canary.0 =16.0.0-beta.0 =16.1.0-canary.0 <16.1.5 (fixed))
- Verified: https://github.com/advisories/GHSA-h25m-26qc-wcjf (GitHub-reviewed advisory GHSA-h25m-26qc-wcjf lists affected ranges: npm next >=13.0.0 =15.1.1-canary.0 =15.2.0-canary.0 =15.3.0-canary.0 =15.4.0-canary.0 =15.5.1-canary.0 =15.6.0-canary.0 =16.0.0-beta.0 =16.1.0-canary.0 <16.1.5)

Commands are suggestions: review each one before running it.

Loading voting…