Skip to content

← Actionable
High, CVSS 7.8

Drupal core Arbitrary PHP code execution

GHSA-gxxj-g9v8-w28p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.9, 8.9.10, 8.8.12, 7.75), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0.0, < 7.75>= 8.0.0, < 8.8.12>= 8.9.0, < 8.9.10>= 9.0.0, < 9.0.9
    Fixed in
    8.8.12, 8.9.10, 9.0.9, 7.75

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The Drupal project uses the PEAR ArchiveTar library. The PEAR ArchiveTar library has released a security update that impacts Drupal. For more information please see: CVE-2020-28948 CVE-2020-28949 Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2, or .tlz file uploads and processes them. To mitigate this issue, prevent untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gxxj-g9v8-w28p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gxxj-g9v8-w28p

Advisory: Drupal core Arbitrary PHP code execution
IDs: GHSA-gxxj-g9v8-w28p
Record: https://patchnext.com/advisories/ghsa-gxxj-g9v8-w28p (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.9, 8.9.10, 8.8.12, 7.75. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0.0, < 7.75; >= 8.0.0, < 8.8.12; >= 8.9.0, < 8.9.10; >= 9.0.0, < 9.0.9; fixed in 8.8.12, 8.9.10, 9.0.9, 7.75

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gxxj-g9v8-w28p (GitHub-reviewed advisory GHSA-gxxj-g9v8-w28p lists affected ranges: Packagist drupal/core >=7.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.9)

Commands are suggestions: review each one before running it.

Loading voting…