ZendFramework Cross-site Scripting vector in Zend_Filter_StripTags
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- >= 1.7.0, < 1.7.6
- Fixed in
- 1.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwpm-pm6x-h7rj lists affected ranges: Packagist zendframework/zendframework1 >=1.7.0 <1.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
ZendFilterStripTags is a filtering class analogous to PHP's striptags() function. In addition to stripping HTML tags and selectively keeping those provided in a whitelist, it also provides the ability to whitelist specific attributes to retain per whitelisted tag. The reporter discovered that attributes that contained whitespace, and in paricular, line breaks, surrounding the attribute assignment operator would not be stripped, regardless of whether or not they were whitelisted. As examples of input affected: When passed to the following code: then the "onclick" attribute would remain, even though it was not specified in the tag's whitelist. This could open potential cross-site scripting attack (XSS) vectors. Recommendations If you were using ZendFilterStripTags and utlizing the attribute whitelisting functionality, you should immediately upgrade to Zend Framework 1.7.6 or above; regardless, it is always best to run the most current version of the framework. Also, if relying on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gwpm-pm6x-h7rj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gwpm-pm6x-h7rj Advisory: ZendFramework Cross-site Scripting vector in `Zend_Filter_StripTags` IDs: GHSA-gwpm-pm6x-h7rj Record: https://patchnext.com/advisories/ghsa-gwpm-pm6x-h7rj (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected >= 1.7.0, < 1.7.6; fixed in 1.7.6 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwpm-pm6x-h7rj (GitHub-reviewed advisory GHSA-gwpm-pm6x-h7rj lists affected ranges: Packagist zendframework/zendframework1 >=1.7.0 <1.7.6) Commands are suggestions: review each one before running it.
Loading voting…