Import loops in account imports, nats-server DoS
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/nats-io/nats-server/v2 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/nats-io/nats-server/v2
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwj5-3vfq-q992 lists affected ranges: Go github.com/nats-io/nats-server/v2 >=0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
(This advisory is canonically <https://advisories.nats.io/CVE/CVE-2020-28466.txt) Problem Description An export/import cycle between accounts could crash the nats-server, after consuming CPU and memory. This issue was fixed publicly in <https://github.com/nats-io/nats-server/pull/1731 in November 2020. The need to call this out as a security issue was highlighted by snyk.io and we are grateful for their assistance in doing so. Organizations which run a NATS service providing access to accounts run by untrusted third parties are affected. See below for an important caveat if running such a service. Affected versions NATS Server Version 2 prior to 2.2.0 + 2.0.0 through and including 2.1.9 are vulnerable. fixed with nats-io/nats-server PR 1731, commit 2e3c226729 Impact The nats-server could be killed, after consuming resources. Workaround The import cycle requires at least two accounts to work; if you have open account sign-up, then restricting new account sign-up might hinder an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gwj5-3vfq-q992
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gwj5-3vfq-q992 Advisory: Import loops in account imports, nats-server DoS IDs: GHSA-gwj5-3vfq-q992 Record: https://patchnext.com/advisories/ghsa-gwj5-3vfq-q992 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/nats-io/nats-server/v2 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/nats-io/nats-server/v2: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - Go github.com/nats-io/nats-server/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/nats-io/nats-server/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwj5-3vfq-q992 (GitHub-reviewed advisory GHSA-gwj5-3vfq-q992 lists affected ranges: Go github.com/nats-io/nats-server/v2 >=0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…