Object state limitation has no effect
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ibexa/core 4.1.2, 4.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ibexa/core
- Affected
- >= 4.0.0, < 4.0.5>= 4.1.0, < 4.1.2
- Fixed in
- 4.1.2, 4.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gvj8-4cj4-h776 lists affected ranges: Packagist ibexa/core >=4.0.0 =4.1.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Object state limitation is a policy you can use in your roles to limit access to content based on specific object state values. Due to a flawed earlier update, these limitations were ineffective in releases made since February 16th 2022. They would grant access to the given content regardless of the object state. Depending on how your frontent is designed, knowing the URL to the content may or may not be required to access it. If you are using object state limitations in your roles, this issue is critical. Please apply the fix as soon as possible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gvj8-4cj4-h776
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gvj8-4cj4-h776 Advisory: Object state limitation has no effect IDs: GHSA-gvj8-4cj4-h776 Record: https://patchnext.com/advisories/ghsa-gvj8-4cj4-h776 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ibexa/core 4.1.2, 4.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ibexa/core: affected >= 4.0.0, < 4.0.5; >= 4.1.0, < 4.1.2; fixed in 4.1.2, 4.0.5 ## Suggested inspection (read-only) - Packagist ibexa/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ibexa/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gvj8-4cj4-h776 (GitHub-reviewed advisory GHSA-gvj8-4cj4-h776 lists affected ranges: Packagist ibexa/core >=4.0.0 =4.1.0 <4.1.2) Commands are suggestions: review each one before running it.
Loading voting…