OpenUSD File Parsing Use-After-Free Remote Code Execution Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (usd-core 25.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI usd-core
- Affected
- <= 25.8
- Fixed in
- 25.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-grjp-54v3-c442 lists affected ranges: PyPI usd-core >=0 <25.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-grjp-54v3-c442 lists affected ranges: PyPI usd-core >=0 <=25.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Patch This is fixed with commit b953092, with the fix available in OpenUSD 25.11 and onwards. Summary We have been advised by Zero Day Initiative that our usage of the USD framework may constitute a Use-After-Free Remote Code Execution Vulnerability. They have sent us the attached file illustrating the issue. Indeed, we see a use after free exception when running the file through our importer with an address sanitizer. zdi-23709-poc0.zip Thanks in advance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-grjp-54v3-c442
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-grjp-54v3-c442
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-grjp-54v3-c442 Advisory: OpenUSD File Parsing Use-After-Free Remote Code Execution Vulnerability IDs: GHSA-grjp-54v3-c442 Record: https://patchnext.com/advisories/ghsa-grjp-54v3-c442 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: usd-core 25.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI usd-core: affected <= 25.8; fixed in 25.11 ## Suggested inspection (read-only) - `python -m pip show usd-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on usd-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-grjp-54v3-c442 (OSV record GHSA-grjp-54v3-c442 lists affected ranges: PyPI usd-core >=0 <25.11 (fixed)) - Verified: https://github.com/advisories/GHSA-grjp-54v3-c442 (GitHub-reviewed advisory GHSA-grjp-54v3-c442 lists affected ranges: PyPI usd-core >=0 <=25.8) Commands are suggestions: review each one before running it.
Loading voting…