Magento LTS vulnerable to stored XSS in admin file form
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.5.0, 19.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- >= 20.0.0, < 20.5.0< 19.5.3
- Fixed in
- 20.5.0, 19.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gp6m-fq6h-cjcx lists affected ranges: Packagist openmage/magento-lts >=20.0.0 =0 <19.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary OpenMage is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Details MageAdminhtmlBlockSystemConfigFormFieldFile does not escape filename value in certain situations. Same as: https://nvd.nist.gov/vuln/detail/CVE-2024-20717 PoC 1. Create empty file with this filename: <img src=x onerror=alert(1).crt 2. Go to System Configuration Sales | Payment Methonds. 3. Click Configure on PayPal Express Checkout. 4. Choose API Certificate from dropdown API Authentication Methods. 5. Choose the XSS-file and click Save Config. 6. Profit, alerts "1" - XSS. 7. Reload, alerts "1" - Stored XSS. Impact Affects admins that have access to any fileupload field in admin in core or custom implementations. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gp6m-fq6h-cjcx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gp6m-fq6h-cjcx Advisory: Magento LTS vulnerable to stored XSS in admin file form IDs: GHSA-gp6m-fq6h-cjcx Record: https://patchnext.com/advisories/ghsa-gp6m-fq6h-cjcx (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.5.0, 19.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected >= 20.0.0, < 20.5.0; < 19.5.3; fixed in 20.5.0, 19.5.3 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gp6m-fq6h-cjcx (GitHub-reviewed advisory GHSA-gp6m-fq6h-cjcx lists affected ranges: Packagist openmage/magento-lts >=20.0.0 =0 <19.5.3) Commands are suggestions: review each one before running it.
Loading voting…