Skip to content

← Actionable
High, CVSS 8.7

Mimekit has vulnerable dependency that can lead to denial of service

GHSA-gmc6-fwg3-75m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mimekit 4.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet mimekit

    Affected
    >= 3.0.0, < 4.7.1
    Fixed in
    4.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Denial of service vulnerability. Details See: https://github.com/advisories/GHSA-447r-wph3-92pm and https://github.com/dotnet/announcements/issues/312 PoC Update System.Security.Cryptography.Pkcs to 8.0.1 so that the transitive dependency with the issue gets updated Impact Denial of service vulnerability. Affects MimeKit (= v3.0.0 and <= v4.7.0) when used to decrypt or verify incoming S/MIME messages as well as importing 3rd-party X.509 certificates for use with encrypting outgoing S/MIME messages.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gmc6-fwg3-75m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gmc6-fwg3-75m5

Advisory: Mimekit has vulnerable dependency that can lead to denial of service
IDs: GHSA-gmc6-fwg3-75m5
Record: https://patchnext.com/advisories/ghsa-gmc6-fwg3-75m5 (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mimekit 4.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet mimekit: affected >= 3.0.0, < 4.7.1; fixed in 4.7.1

## Suggested inspection (read-only)
- NuGet mimekit: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mimekit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gmc6-fwg3-75m5 (GitHub-reviewed advisory GHSA-gmc6-fwg3-75m5 lists affected ranges: NuGet mimekit >=3.0.0 <4.7.1)

Commands are suggestions: review each one before running it.

Loading voting…