Skip to content

← Actionable
High, CVSS 7.1

Curio exposes database credentials to users with network access through verbose HTTP error responses

GHSA-gj6x-q8rh-wj6x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/filecoin-project/curio 1.27.3-rc2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple HTTP handlers in Curio passed raw database error messages to HTTP clients via http.Error(). When the PostgreSQL/YugabyteDB driver (pgx) returned errors, these could contain the database connection string — including hostname, port, username, and password. Additionally, the internal connection string was constructed with the plaintext password embedded in the URL, which was also included in startup error messages and could surface in logs. Details Three components were affected: 1. PDP handlers (pdp/handlers.go) — 18+ HTTP error paths passed err.Error() directly to HTTP responses. While these endpoints require ECDSA JWT authentication, an authenticated client (e.g., a FilPay service) that triggered a database error would receive the raw pgx error in the HTTP response body. Present since PDP was introduced in v1.25.1. 2. Market mk12 deal status (market/mk12/mk12utils.go) — The GetDealStatus handler included err.Error() in error responses: "failed to query the db for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gj6x-q8rh-wj6x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gj6x-q8rh-wj6x

Advisory: Curio exposes database credentials to users with network access through verbose HTTP error responses
IDs: GHSA-gj6x-q8rh-wj6x
Record: https://patchnext.com/advisories/ghsa-gj6x-q8rh-wj6x (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/filecoin-project/curio 1.27.3-rc2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/filecoin-project/curio: affected >= 1.24.3, <= 1.27.2; fixed in 1.27.3-rc2

## Suggested inspection (read-only)
- Go github.com/filecoin-project/curio: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/filecoin-project/curio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gj6x-q8rh-wj6x (GitHub-reviewed advisory GHSA-gj6x-q8rh-wj6x lists affected ranges: Go github.com/filecoin-project/curio >=1.24.3 <=1.27.2)

Commands are suggestions: review each one before running it.

Loading voting…