Skip to content

← Actionable
Medium, CVSS 6.3amended

HTML injection in JupyterLite leading to DOM Clobbering

GHSA-gj55-2xf9-67rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlite-core 0.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data accessible from JupyterLite and perform arbitrary actions in JupyterLite environment. Patches JupyterLite 0.4.1 was patched. Workarounds There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: - @jupyterlab/mathjax-extension:plugin - users will loose ability to preview mathematical equations - @jupyterlab/markdownviewer-extension:plugin - users will loose ability to open Markdown previews - @jupyterlab/mathjax2-extension:plugin (if installed with optional jupyterlab-mathjax2 package) - an older version of the mathjax plugin for JupyterLab 4.x To disable these extensions populate the disabledExtensions key in jupyter-config-data stanza of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gj55-2xf9-67rq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gj55-2xf9-67rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gj55-2xf9-67rq

Advisory: HTML injection in JupyterLite leading to DOM Clobbering
IDs: GHSA-gj55-2xf9-67rq
Record: https://patchnext.com/advisories/ghsa-gj55-2xf9-67rq (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlite-core 0.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlite-core: affected < 0.4.1; fixed in 0.4.1

## Suggested inspection (read-only)
- `python -m pip show jupyterlite-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlite-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gj55-2xf9-67rq (OSV record GHSA-gj55-2xf9-67rq lists affected ranges: PyPI jupyterlite-core >=0 <0.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-gj55-2xf9-67rq (GitHub-reviewed advisory GHSA-gj55-2xf9-67rq lists affected ranges: PyPI jupyterlite-core >=0 <0.4.1)

Commands are suggestions: review each one before running it.

Loading voting…