Skip to content

← Actionable
High, CVSS 7.3

eKuiper /config/uploads API arbitrary file writing may lead to RCE

GHSA-gj54-gwj9-x2c6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/lf-edge/ekuiper/v2

    Affected
    < 2.2.0
    Fixed in
    2.2.0
  • Go github.com/lf-edge/ekuiper

    Affected
    <= 1.14.7
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary eKuiper /config/uploads API supports accessing remote web URLs and saving files in the local upload directory, but there are no security restrictions, resulting in arbitrary file writing through ../. If run with root privileges, RCE can be achieved by writing crontab files or ssh keys. Details - The fc.Name parameter do not safely filtered. PoC Impact Tested and verified only on 1.14.3 and 1.14.1, theoretically all versions using this code could be affected. 1. SSRF 2. Path-Travel 3. May leads to RCE The reporters is m0d9 from Tencent YunDing Lab.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gj54-gwj9-x2c6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gj54-gwj9-x2c6

Advisory: eKuiper /config/uploads API arbitrary file writing may lead to RCE
IDs: GHSA-gj54-gwj9-x2c6
Record: https://patchnext.com/advisories/ghsa-gj54-gwj9-x2c6 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/lf-edge/ekuiper/v2 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/lf-edge/ekuiper/v2: affected < 2.2.0; fixed in 2.2.0
- Go github.com/lf-edge/ekuiper: affected <= 1.14.7

## Suggested inspection (read-only)
- Go github.com/lf-edge/ekuiper/v2: check the installed version with your package manager.
- Go github.com/lf-edge/ekuiper: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/lf-edge/ekuiper/v2, github.com/lf-edge/ekuiper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gj54-gwj9-x2c6 (GitHub-reviewed advisory GHSA-gj54-gwj9-x2c6 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 =0 <=1.14.7)

Commands are suggestions: review each one before running it.

Loading voting…