instagrapi: Unsafe signup challenge path handling in instagrapi
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (instagrapi 2.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI instagrapi
- Affected
- < 2.6.9
- Fixed in
- 2.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ggxf-37hm-9wqf lists affected ranges: PyPI instagrapi >=0 <2.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggxf-37hm-9wqf lists affected ranges: PyPI instagrapi >=0 <2.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
instagrapi versions before 2.6.9 accepted server-supplied signup challenge paths and used them to build request URLs before validating that the paths were relative Instagram API paths. A malicious or tampered challenge payload could cause challenge handling requests to be sent outside the intended Instagram host with the client\'s existing session headers. Version 2.6.9 validates challenge paths before building URLs, solving captcha challenges, or submitting phone/SMS challenge forms.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-ggxf-37hm-9wqf
- Revision 1 · created ·
Published from osv record GHSA-ggxf-37hm-9wqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-ggxf-37hm-9wqf Advisory: instagrapi: Unsafe signup challenge path handling in instagrapi IDs: GHSA-ggxf-37hm-9wqf Record: https://patchnext.com/advisories/ghsa-ggxf-37hm-9wqf (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: instagrapi 2.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI instagrapi: affected < 2.6.9; fixed in 2.6.9 ## Suggested inspection (read-only) - `python -m pip show instagrapi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on instagrapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ggxf-37hm-9wqf (OSV record GHSA-ggxf-37hm-9wqf lists affected ranges: PyPI instagrapi >=0 <2.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-ggxf-37hm-9wqf (GitHub-reviewed advisory GHSA-ggxf-37hm-9wqf lists affected ranges: PyPI instagrapi >=0 <2.6.9) Commands are suggestions: review each one before running it.
Loading voting…