Skip to content

← Actionable
Critical, CVSS 9.8amended

CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0

GHSA-ggpf-24jw-3fcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.8.0
    Fixed in
    0.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54 reported a vulnerability where loading a malicious model could result in code execution on the vllm host. The fix applied to specify weightsonly=True to calls to torch.load() did not solve the problem prior to PyTorch 2.6.0. PyTorch has issued a new CVE about this problem: https://github.com/advisories/GHSA-53q9-r3pm-6pq6 This means that versions of vLLM using PyTorch before 2.6.0 are vulnerable to this problem. Background Knowledge When users install VLLM according to the official manual But the version of PyTorch is specified in the requirements. txt file So by default when the user install VLLM, it will install the PyTorch with version 2.5.1 In CVE-2025-24357, weightsonly=True was used for patching, but we know this is not secure. Because we found that using Weightsonly=True in pyTorch before 2.5.1 was unsafe Here, we use this interface to prove that it is not safe. Fix update PyTorch version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ggpf-24jw-3fcw

  2. Revision 1 · created ·

    Published from osv record GHSA-ggpf-24jw-3fcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-ggpf-24jw-3fcw

Advisory: CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0
IDs: GHSA-ggpf-24jw-3fcw
Record: https://patchnext.com/advisories/ghsa-ggpf-24jw-3fcw (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ggpf-24jw-3fcw (OSV record GHSA-ggpf-24jw-3fcw lists affected ranges: PyPI vllm >=0 <0.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ggpf-24jw-3fcw (GitHub-reviewed advisory GHSA-ggpf-24jw-3fcw lists affected ranges: PyPI vllm >=0 <0.8.0)

Commands are suggestions: review each one before running it.

Loading voting…