Skip to content

← Actionable
Critical, CVSS 9.2amended

Trigger.dev: V1 coordinator default-secret unauth Socket.IO

CVE-2026-114088GHSA-gg6r-gp4c-89hp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trigger.dev 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-114088: 0.40% estimated exploitation activity in the next 30 days; percentile 34.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR The /coordinator Socket.IO namespace mounts on every webapp boot and authenticates with a default secret ("coordinator-secret") baked into source. The override variable isn't documented in the self-host docs, .env.example, or helm values, so any operator who didn't read source ships with the default. Once connected, READYFOREXECUTION returns the run's decrypted env vars. Anyone who can reach a default-config self-hosted webapp can pull production secrets out of any run whose internal id they can find. Vulnerabilities This attack is made possible by 3 vulnerabilities in Trigger.dev: 1. Hardcoded default authentication secret (CWE-798, Critical) PROVIDERSECRET and COORDINATORSECRET are declared with .default("provider-secret") / .default("coordinator-secret") in apps/webapp/app/env.server.ts:289-290. The values are present in the public source repo, neither var is documented in docs/self-hosting/env/.mdx, hosting/docker/.env.example, or hosting/k8s/helm/values.yaml, and the auth…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-gg6r-gp4c-89hp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-gg6r-gp4c-89hp

  4. Revision 1 · created ·

    Published from ghsa record GHSA-gg6r-gp4c-89hp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114088

Advisory: Trigger.dev: V1 coordinator default-secret unauth Socket.IO
IDs: CVE-2026-114088, GHSA-gg6r-gp4c-89hp
Record: https://patchnext.com/advisories/ghsa-gg6r-gp4c-89hp (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trigger.dev 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trigger.dev: affected < 4.5.4; fixed in 4.5.4

## Suggested inspection (read-only)
- `npm ls trigger.dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trigger.dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg6r-gp4c-89hp (GitHub-reviewed advisory GHSA-gg6r-gp4c-89hp lists affected ranges: npm trigger.dev >=0 <4.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-gg6r-gp4c-89hp (OSV record GHSA-gg6r-gp4c-89hp lists affected ranges: npm trigger.dev >=0 <4.5.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…