Bypassing Kyverno Policies via Double Policy Exceptions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kyverno/kyverno 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.9.0, <= 1.12.7
- Fixed in
- 1.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gg4x-fgg2-h9w9 lists affected ranges: Go github.com/kyverno/kyverno >=1.9.0 <=1.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary If a cluster has a Kyverno policy in enforce mode and there are two exceptions, this allows the policy to be bypassed, even if the first exception is more restrictive than the second. Details The following policy was applied: And two exceptions: Trying to apply such a yaml will result in the expected ban: <img width="855" height="483" alt="Снимок экрана 2025-09-04 в 13 35 46" src="https://github.com/user-attachments/assets/deb28128-52fb-4f5f-a9bd-b68eefd411b2" / However, if the load name is changed to satisfy the second exception, the restrictions can be bypassed: <img width="449" height="386" alt="Снимок экрана 2025-09-04 в 13 37 09" src="https://github.com/user-attachments/assets/8d5ad1e2-6d16-4768-8741-f11363bb9b22" / It turns out that the second exception is higher in priority for Kyverno and allows for bypass of the restrictions. Impact The security restrictions can be bypassed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gg4x-fgg2-h9w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gg4x-fgg2-h9w9 Advisory: Bypassing Kyverno Policies via Double Policy Exceptions IDs: GHSA-gg4x-fgg2-h9w9 Record: https://patchnext.com/advisories/ghsa-gg4x-fgg2-h9w9 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kyverno/kyverno 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kyverno/kyverno: affected >= 1.9.0, <= 1.12.7; fixed in 1.13.0 ## Suggested inspection (read-only) - Go github.com/kyverno/kyverno: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kyverno/kyverno. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gg4x-fgg2-h9w9 (GitHub-reviewed advisory GHSA-gg4x-fgg2-h9w9 lists affected ranges: Go github.com/kyverno/kyverno >=1.9.0 <=1.12.7) Commands are suggestions: review each one before running it.
Loading voting…