ZendFramework potential remote code execution in zend-mail via Sendmail adapter
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework 2.4.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework
- Affected
- >= 2.0.0, < 2.4.11
- Fixed in
- 2.4.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gff2-p6vm-3p8g lists affected ranges: Packagist zendframework/zendframework >=2.0.0 <2.4.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
When using the zend-mail component to send email via the Zend\Mail\Transport\Sendmail transport, a malicious user may be able to inject arbitrary parameters to the system sendmail program. The attack is performed by providing additional quote characters within an address; when unsanitized, they can be interpreted as additional command line arguments, leading to the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gff2-p6vm-3p8g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-gff2-p6vm-3p8g Advisory: ZendFramework potential remote code execution in zend-mail via Sendmail adapter IDs: GHSA-gff2-p6vm-3p8g Record: https://patchnext.com/advisories/ghsa-gff2-p6vm-3p8g (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework 2.4.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework: affected >= 2.0.0, < 2.4.11; fixed in 2.4.11 ## Suggested inspection (read-only) - Packagist zendframework/zendframework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gff2-p6vm-3p8g (GitHub-reviewed advisory GHSA-gff2-p6vm-3p8g lists affected ranges: Packagist zendframework/zendframework >=2.0.0 <2.4.11) Commands are suggestions: review each one before running it.
Loading voting…