Skip to content

← Actionable
Medium, CVSS 4.8

eZ Platform Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widget

GHSA-gc5h-6jx9-q2qh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezplatform-admin-ui 3.3.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file. The fix ensures XSS is escaped. Patches See "Patched versions". Commit: https://github.com/ezsystems/ezplatform-admin-ui/commit/7a9f991b200fa5a03d49cd07f50577c8bc90a30b Workarounds None. References - https://developers.ibexa.co/security-advisories/ibexa-sa-2024-004-dom-based-xss-in-file-upload - https://github.com/ezsystems/ezplatform-admin-ui/commit/7a9f991b200fa5a03d49cd07f50577c8bc90a30b - https://github.com/ibexa/admin-ui/security/advisories/GHSA-qm44-wjm2-pr59 Credit This vulnerability was discovered and reported to Ibexa by Alec Romano: https://github.com/4rdr We thank them for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gc5h-6jx9-q2qh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-gc5h-6jx9-q2qh

Advisory: eZ Platform Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widget
IDs: GHSA-gc5h-6jx9-q2qh
Record: https://patchnext.com/advisories/ghsa-gc5h-6jx9-q2qh (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezplatform-admin-ui 3.3.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/ezplatform-admin-ui: affected >= 3.3.0, < 3.3.39; fixed in 3.3.39

## Suggested inspection (read-only)
- Packagist ezsystems/ezplatform-admin-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/ezplatform-admin-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gc5h-6jx9-q2qh (GitHub-reviewed advisory GHSA-gc5h-6jx9-q2qh lists affected ranges: Packagist ezsystems/ezplatform-admin-ui >=3.3.0 <3.3.39)

Commands are suggestions: review each one before running it.

Loading voting…