Skip to content

← Actionable
Medium, CVSS 4.6amended

Trix has a stored XSS vulnerability through its attachment attribute

GHSA-g9jg-w8vm-g96v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (action_text-trix 2.1.16; trix 2.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The Trix editor, in versions prior to 2.1.16, is vulnerable to XSS attacks through attachment payloads. An attacker could inject malicious code into a data-trix-attachment attribute that, when rendered as HTML and clicked on, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.16 or later. Resources The XSS vulnerability was reported by HackerOne researcher michaelcheers.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g9jg-w8vm-g96v

  2. Revision 1 · created ·

    Published from osv record GHSA-g9jg-w8vm-g96v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g9jg-w8vm-g96v

Advisory: Trix has a stored XSS vulnerability through its attachment attribute
IDs: GHSA-g9jg-w8vm-g96v
Record: https://patchnext.com/advisories/ghsa-g9jg-w8vm-g96v (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: action_text-trix 2.1.16; trix 2.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems action_text-trix: affected < 2.1.16; fixed in 2.1.16
- npm trix: affected < 2.1.16; fixed in 2.1.16

## Suggested inspection (read-only)
- RubyGems action_text-trix: check the installed version with your package manager.
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on action_text-trix, trix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g9jg-w8vm-g96v (OSV record GHSA-g9jg-w8vm-g96v lists affected ranges: npm trix >=0 =0 <2.1.16 (fixed))
- Verified: https://github.com/advisories/GHSA-g9jg-w8vm-g96v (GitHub-reviewed advisory GHSA-g9jg-w8vm-g96v lists affected ranges: npm trix >=0 =0 <2.1.16)

Commands are suggestions: review each one before running it.

Loading voting…