Skip to content

← Actionable
High, CVSS 7.5

Thelia authentication bypass vulnerability

GHSA-g8pg-33v4-9r96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (thelia/thelia 2.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist thelia/thelia

    Affected
    >= 2.0.0-beta1, < 2.1.3
    Fixed in
    2.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

An authentication bypass was identifed in thelia/thelia project for customer and admin. This vulnerability is present from version 2.0.0-beta1 and is fixed in 2.1.3 and 2.2.0-alpha1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g8pg-33v4-9r96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g8pg-33v4-9r96

Advisory: Thelia authentication bypass vulnerability
IDs: GHSA-g8pg-33v4-9r96
Record: https://patchnext.com/advisories/ghsa-g8pg-33v4-9r96 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: thelia/thelia 2.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist thelia/thelia: affected >= 2.0.0-beta1, < 2.1.3; fixed in 2.1.3

## Suggested inspection (read-only)
- Packagist thelia/thelia: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on thelia/thelia.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g8pg-33v4-9r96 (GitHub-reviewed advisory GHSA-g8pg-33v4-9r96 lists affected ranges: Packagist thelia/thelia >=2.0.0-beta1 <2.1.3)

Commands are suggestions: review each one before running it.

Loading voting…