Insufficient type validation in pocketmine/pocketmine-mp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 4.2.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pocketmine/pocketmine-mp
- Affected
- < 4.2.9
- Fixed in
- 4.2.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g5rr-p69h-7v3g lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <4.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact When an inventory interaction is performed (e.g. moving an item around an inventory), the client sends a serialized version of the itemstack to the server, which the server then deserializes and compares against its own copy. If the copies don't match, the transaction is invalid. This involves deserializing item NBT from the client, which allows for bogus data to be provided. Usually, this is harmless, but in this particular case, it could result in crashes on certain types of bad data (e.g. incorrect ListTag type provided for the CanDestroy tag). Patches This is fixed in 4.2.9 by commit 5a98b08ee8dc8ff14862cd83d2e4af9d212fefc2. Workarounds It's non-trivial to workaround this, but can be done by handling InventoryTransactionPacket and PlayerAuthInputPacket to scrub inbound transaction data of bogus NBT that would cause these crashes. For more information Email us at team@pmmp.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g5rr-p69h-7v3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-g5rr-p69h-7v3g Advisory: Insufficient type validation in pocketmine/pocketmine-mp IDs: GHSA-g5rr-p69h-7v3g Record: https://patchnext.com/advisories/ghsa-g5rr-p69h-7v3g (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 4.2.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pocketmine/pocketmine-mp: affected < 4.2.9; fixed in 4.2.9 ## Suggested inspection (read-only) - Packagist pocketmine/pocketmine-mp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pocketmine/pocketmine-mp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g5rr-p69h-7v3g (GitHub-reviewed advisory GHSA-g5rr-p69h-7v3g lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <4.2.9) Commands are suggestions: review each one before running it.
Loading voting…