Skip to content

← Actionable
High, CVSS 8.1amended

LiteLLM: internal_user_viewer arbitrary local file read via vertex_ai_credentials

GHSA-g5ff-637f-6q2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.95.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    < 1.95.0
    Fixed in
    1.95.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated LiteLLM proxy user could read arbitrary local files from the proxy runtime by sending a crafted `vertex_ai_credentials` value to `/utils/transform_request`. The request-body safety blocklist rejected `vertex_credentials` but missed its alias `vertex_ai_credentials`, which let the value reach the Vertex AI credential loader and trigger a file read that is sent to an attacker-controlled URL.

Impact A low-privilege authenticated user (only `internal_user_viewer`, obtainable through SSO login on many deployments) could read any file readable by the LiteLLM process. Reading files such as `/proc/self/environ` can disclose `LITELLM_MASTER_KEY` and provider API keys, so the impact can escalate to full proxy-admin control.

Remediation Upgrade to `1.95.0` or later. The fix adds the missing alias to the request-body blocklist, so no configuration change is needed once you upgrade. There is no reliable configuration workaround on affected versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-g5ff-637f-6q2m

  2. Revision 1 · created ·

    Published from ghsa record GHSA-g5ff-637f-6q2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g5ff-637f-6q2m

Advisory: LiteLLM: internal_user_viewer arbitrary local file read via `vertex_ai_credentials`
IDs: GHSA-g5ff-637f-6q2m
Record: https://patchnext.com/advisories/ghsa-g5ff-637f-6q2m (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.95.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected < 1.95.0; fixed in 1.95.0

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5ff-637f-6q2m (OSV record GHSA-g5ff-637f-6q2m lists affected ranges: PyPI litellm >=0 <1.95.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g5ff-637f-6q2m (GitHub-reviewed advisory GHSA-g5ff-637f-6q2m lists affected ranges: PyPI litellm >=0 <1.95.0)

Commands are suggestions: review each one before running it.

Loading voting…