SilverStripe Vulnerability on 'isDev', 'isTest' and 'flush' $_GET validation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.1.13, 3.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- >= 3.0.0, <= 3.0.13>= 3.1.0, < 3.1.13
- Fixed in
- 3.1.13, 3.0.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4hp-pfvf-vm5w lists affected ranges: Packagist silverstripe/framework >=3.0.0 =3.1.0 <3.1.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
When a secure token parameter is provided to a SilverStripe site (such as isDev or flush) an empty token parameter can be provided in order to bypass normal authentication parameters. For instance, http://www.mysite.com/?isDev=1&isDevtoken will force a site to dev mode. Alternatively, "flush" could also be used in succession to cause excessive load on a victim site and risk denial of service. The fix in this case is to ensure that empty tokens fail the validation check.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g4hp-pfvf-vm5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-g4hp-pfvf-vm5w Advisory: SilverStripe Vulnerability on 'isDev', 'isTest' and 'flush' $_GET validation IDs: GHSA-g4hp-pfvf-vm5w Record: https://patchnext.com/advisories/ghsa-g4hp-pfvf-vm5w (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.1.13, 3.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected >= 3.0.0, <= 3.0.13; >= 3.1.0, < 3.1.13; fixed in 3.1.13, 3.0.14 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g4hp-pfvf-vm5w (GitHub-reviewed advisory GHSA-g4hp-pfvf-vm5w lists affected ranges: Packagist silverstripe/framework >=3.0.0 =3.1.0 <3.1.13) Commands are suggestions: review each one before running it.
Loading voting…