Skip to content

← Actionable
High, CVSS 7.5amended

fido2-lib is vulnerable to DoS via cbor-extract heap buffer over-read in CBOR attestation parsing

GHSA-g3qj-j598-cxmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fido2-lib 3.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary fido2-lib v3.x depends on cbor-x (~1.6.0), which optionally pulls in cbor-extract (C++ native addon). cbor-extract <= 2.2.0 has a heap buffer over-read in extractStrings() — a 5-byte CBOR payload crashes Node.js with SIGSEGV. No JS exception, no try/catch, process dead. The crash triggers during WebAuthn registration when the server decodes the attestation object. An attacker sends a crafted authenticator response to the registration endpoint — single request, unauthenticated, instant kill. Fixed in cbor-extract@2.2.1 / cbor-x@1.6.3 (2026-03-08). fido2-lib@3.5.7 still pins cbor-x ~1.6.0 which resolves to vulnerable cbor-extract. Affected versions fido2-lib <= 3.5.7 (introduced cbor-x dependency). fido2-lib 2.x uses the old cbor package — not affected. Only affects systems where cbor-extract native addon is installed (prebuilt binary available for platform). Pure JS fallback is safe. PoC CBOR text string header claiming 268MB in a 5-byte buffer. extractStrings() in extract.cpp…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g3qj-j598-cxmq

  2. Revision 1 · created ·

    Published from osv record GHSA-g3qj-j598-cxmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g3qj-j598-cxmq

Advisory: fido2-lib is vulnerable to DoS via cbor-extract heap buffer over-read in CBOR attestation parsing
IDs: GHSA-g3qj-j598-cxmq
Record: https://patchnext.com/advisories/ghsa-g3qj-j598-cxmq (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fido2-lib 3.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fido2-lib: affected <= 3.5.7; fixed in 3.5.8

## Suggested inspection (read-only)
- `npm ls fido2-lib --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fido2-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g3qj-j598-cxmq (OSV record GHSA-g3qj-j598-cxmq lists affected ranges: npm fido2-lib >=0 <3.5.8 (fixed))
- Verified: https://github.com/advisories/GHSA-g3qj-j598-cxmq (GitHub-reviewed advisory GHSA-g3qj-j598-cxmq lists affected ranges: npm fido2-lib >=0 <=3.5.7)

Commands are suggestions: review each one before running it.

Loading voting…