Skip to content

← Actionable
High, CVSS 7.5amended

league/commonmark: Denial of service via adjacent inline attribute blocks

GHSA-g2gp-3wwq-f4ph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact With the Attributes extension enabled, AttributesListener::findTargetAndDirection() resolves each attribute node's target by walking outward through its siblings. For a run of N adjacent inline attribute blocks placed at the start of a block (with nothing to their left), each node scans the entire sibling list to the far-right end before giving up and falling back to the parent. Each resolution is therefore Θ(N) and the whole run is Θ(N²). Reaching the path requires AttributesExtension (opt-in, but first-party: League\CommonMark\Extension\Attributes\AttributesExtension). No other configuration matters — the quadratic walk runs unconditionally during parsing and is not gated by the attributes/allow allow-list, the on hardening added in 2.7.0, or allowunsafelinks. An unauthenticated attacker can submit a ~32 KB input ({#a} repeated 8,000 times) that takes over 5 seconds to convert, with time growing quadratically in input length — a cheap denial of service. Availability impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g2gp-3wwq-f4ph

  2. Revision 1 · created ·

    Published from osv record GHSA-g2gp-3wwq-f4ph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g2gp-3wwq-f4ph

Advisory: league/commonmark: Denial of service via adjacent inline attribute blocks
IDs: GHSA-g2gp-3wwq-f4ph
Record: https://patchnext.com/advisories/ghsa-g2gp-3wwq-f4ph (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: league/commonmark 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist league/commonmark: affected >= 1.5.0, < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- Packagist league/commonmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on league/commonmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2gp-3wwq-f4ph (OSV record GHSA-g2gp-3wwq-f4ph lists affected ranges: Packagist league/commonmark >=1.5.0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g2gp-3wwq-f4ph (GitHub-reviewed advisory GHSA-g2gp-3wwq-f4ph lists affected ranges: Packagist league/commonmark >=1.5.0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…