langchain-nvidia-ai-endpoints has local file disclosure through VLM image inputs
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-nvidia-ai-endpoints 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-nvidia-ai-endpoints
- Affected
- <= 1.4.1
- Fixed in
- 1.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g28h-2cmm-rj9x lists affected ranges: PyPI langchain-nvidia-ai-endpoints >=0 <=1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g28h-2cmm-rj9x lists affected ranges: PyPI langchain-nvidia-ai-endpoints >=0 <1.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary langchain-nvidia-ai-endpoints versions before 1.4.2 accepted local filesystem paths as image inputs for Vision Language Model (VLM) requests. If an application passed attacker-controlled image input to ChatNVIDIA or VLM reranking APIs, an attacker could cause files readable by the application process to be read and included in the outbound request to the configured NVIDIA/NIM model endpoint. Impact Applications are affected if they use VLM image inputs with ChatNVIDIA or NVIDIARerank and allow untrusted users to control image URLs or document image metadata. An attacker who can control those inputs may be able to read local files accessible to the application process. Applications that do not use VLM image inputs, or that only pass trusted image references, are not affected. Patched Version Upgrade to langchain-nvidia-ai-endpoints = 1.4.2. The patched version rejects raw local filesystem paths for VLM image inputs. Supported inputs are remote URLs, data:image/...;base64,...…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g28h-2cmm-rj9x
- Revision 2 · amended ·
Amended from osv record GHSA-g28h-2cmm-rj9x
- Revision 1 · created ·
Published from ghsa record GHSA-g28h-2cmm-rj9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-g28h-2cmm-rj9x Advisory: langchain-nvidia-ai-endpoints has local file disclosure through VLM image inputs IDs: GHSA-g28h-2cmm-rj9x Record: https://patchnext.com/advisories/ghsa-g28h-2cmm-rj9x (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-nvidia-ai-endpoints 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-nvidia-ai-endpoints: affected <= 1.4.1; fixed in 1.4.2 ## Suggested inspection (read-only) - `python -m pip show langchain-nvidia-ai-endpoints`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-nvidia-ai-endpoints. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g28h-2cmm-rj9x (GitHub-reviewed advisory GHSA-g28h-2cmm-rj9x lists affected ranges: PyPI langchain-nvidia-ai-endpoints >=0 <=1.4.1) - Verified: https://osv.dev/vulnerability/GHSA-g28h-2cmm-rj9x (OSV record GHSA-g28h-2cmm-rj9x lists affected ranges: PyPI langchain-nvidia-ai-endpoints >=0 <1.4.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…