Skip to content

← Actionable
Unratedamended

CSRF Vuln can expose user's QRcode

GHSA-fxq4-r6mr-9x64

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-security-too 3.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact When a user is setting up two-factor authentication using an authenticator app, a QRcode is generated and made available via a GET request to /tf-qrcode. Since GETs do not have any CSRF protection, it is possible a malicious 3rd party could access the QRcode and therefore gain access to two-factor authentication codes. Note that the /tf-qrcode endpoint is ONLY accessible while the user is initially setting up their device. Once setup is complete, there is no vulnerability. Patches This is fixed in the upcoming 4.0.0 release. Workarounds You can provide your own URL for fetching the QRcode by defining SECURITYTWOFACTORQRCODEURL and providing your own implementation (that presumably required a POST with CSRF protection). This would require changing the two-factor setup template as well. References None. For more information If you have any questions or comments about this advisory: Read this pull request: #423

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fxq4-r6mr-9x64

  2. Revision 1 · created ·

    Published from osv record GHSA-fxq4-r6mr-9x64

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-fxq4-r6mr-9x64

Advisory: CSRF Vuln can expose user's QRcode
IDs: GHSA-fxq4-r6mr-9x64
Record: https://patchnext.com/advisories/ghsa-fxq4-r6mr-9x64 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-security-too 3.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-security-too: affected >= 3.2.0, < 3.4.5; fixed in 3.4.5

## Suggested inspection (read-only)
- `python -m pip show flask-security-too`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-security-too.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxq4-r6mr-9x64 (OSV record GHSA-fxq4-r6mr-9x64 lists affected ranges: PyPI flask-security-too >=3.2.0 <3.4.5 (fixed))
- Verified: https://github.com/advisories/GHSA-fxq4-r6mr-9x64 (GitHub-reviewed advisory GHSA-fxq4-r6mr-9x64 lists affected ranges: PyPI flask-security-too >=3.2.0 <3.4.5)

Commands are suggestions: review each one before running it.

Loading voting…