Skip to content

← Actionable
Unrated

Opened exploitable ports in default docker-compose.yaml in go-ipfs

GHSA-fx5p-f64h-93xc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ipfs/go-ipfs 0.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Allows admin API access to the IPFS node. Who ? This affects people running the docker-compose.yaml service in an environment where the docker host is directly attached to a public or untrusted IP. In the vulnerable version, the private API endpoint is publicly forwarded by exposing it as 0.0.0.0:5001 on the host machine. If the host machine is hidden behind a firewall or NAT (and the LAN is trusted for NAT), this is not an immediate issue because of the protection from the firewall or NAT. That said, we still recommend users update to follow security best practices of not putting unnecessary dependency on a working firewall. Patches This issue is in docker-compose.yaml. Users need to replace their current docker-compose.yaml file with a version 0.12.1 or later. There is no need to update any of the binaries. Users running previous versions like 0.12.0 or earlier can download the 0.12.1 docker-compose.yaml file. You can replace a vulnerable docker-compose.yaml file with a the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fx5p-f64h-93xc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-fx5p-f64h-93xc

Advisory: Opened exploitable ports in default docker-compose.yaml in go-ipfs
IDs: GHSA-fx5p-f64h-93xc
Record: https://patchnext.com/advisories/ghsa-fx5p-f64h-93xc (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ipfs/go-ipfs 0.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ipfs/go-ipfs: affected >= 0.11.0, < 0.12.1; fixed in 0.12.1

## Suggested inspection (read-only)
- Go github.com/ipfs/go-ipfs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ipfs/go-ipfs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fx5p-f64h-93xc (GitHub-reviewed advisory GHSA-fx5p-f64h-93xc lists affected ranges: Go github.com/ipfs/go-ipfs >=0.11.0 <0.12.1)

Commands are suggestions: review each one before running it.

Loading voting…