Ech0 Comment Panel Endpoints Missing RequireScopes Middleware — Scoped Access Token Bypass
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lin-snow/ech0 4.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.4.3
- Fixed in
- 4.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwg7-53p4-g33c lists affected ranges: Go github.com/lin-snow/ech0 >=0 <4.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary All 9 comment panel admin endpoints (/api/panel/comments/) are missing RequireScopes() middleware, while every other admin endpoint in the application enforces scope-based authorization on access tokens. An admin-issued access token scoped to minimal permissions (e.g., echo:read only) can perform full comment moderation operations including listing, approving, rejecting, deleting comments, and modifying comment system settings. Details The access token scope enforcement system works as follows: JWTAuthMiddleware (internal/middleware/auth.go) parses any valid JWT and injects a viewer into the request context. The RequireScopes() middleware (internal/middleware/scope.go:14) then checks whether the token is an access token and, if so, validates that it carries the required scopes. Session tokens are passed through without scope checks (by design — sessions represent full user authority). Every admin route group applies RequireScopes() per-handler: - internal/router/echo.go —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fwg7-53p4-g33c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fwg7-53p4-g33c Advisory: Ech0 Comment Panel Endpoints Missing RequireScopes Middleware — Scoped Access Token Bypass IDs: GHSA-fwg7-53p4-g33c Record: https://patchnext.com/advisories/ghsa-fwg7-53p4-g33c (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/lin-snow/ech0 4.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lin-snow/ech0: affected < 4.4.3; fixed in 4.4.3 ## Suggested inspection (read-only) - Go github.com/lin-snow/ech0: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lin-snow/ech0. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fwg7-53p4-g33c (GitHub-reviewed advisory GHSA-fwg7-53p4-g33c lists affected ranges: Go github.com/lin-snow/ech0 >=0 <4.4.3) Commands are suggestions: review each one before running it.
Loading voting…