Skip to content

← Actionable
High, CVSS 8.5

LF Edge eKuiper vulnerable to File Path Traversal leading to file replacement

GHSA-fv2p-qj5p-wqq4

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/lf-edge/ekuiper/v2

    Affected
    < 2.2.0
    Fixed in
    2.2.0
  • Go github.com/lf-edge/ekuiper

    Affected
    <= 1.14.7
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Path traversal is also known as directory traversal. These vulnerabilities enable an attacker to read arbitrary files on the server that is running an application. In this case, an attacker might be able to write to arbitrary files on the server, allowing them to modify application data or behavior, and ultimately take full control of the server. Details The file handler function trusts the filename provided by the user. This includes the cases when the user uses a path instead of the filename. This makes possible to write arbitrary files to the system and replace the files owned by kuiper user on the filesystem. The vulnerable function is fileUploadHandler which is shown below: https://github.com/lf-edge/ekuiper/blob/1e6b6b6601445eb05316532f5fbef7f0a863ecfe/internal/server/rest.go#L329-L359 Exploitation of this vulnerability allows an attacker to rewrite the files owned by ekuiper including the main kuiper binaries as they are owned by kuiper user: PoC 0. The files should be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fv2p-qj5p-wqq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-fv2p-qj5p-wqq4

Advisory: LF Edge eKuiper vulnerable to File Path Traversal leading to file replacement
IDs: GHSA-fv2p-qj5p-wqq4
Record: https://patchnext.com/advisories/ghsa-fv2p-qj5p-wqq4 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/lf-edge/ekuiper/v2 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/lf-edge/ekuiper/v2: affected < 2.2.0; fixed in 2.2.0
- Go github.com/lf-edge/ekuiper: affected <= 1.14.7

## Suggested inspection (read-only)
- Go github.com/lf-edge/ekuiper/v2: check the installed version with your package manager.
- Go github.com/lf-edge/ekuiper: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/lf-edge/ekuiper/v2, github.com/lf-edge/ekuiper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fv2p-qj5p-wqq4 (GitHub-reviewed advisory GHSA-fv2p-qj5p-wqq4 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 =0 <=1.14.7)

Commands are suggestions: review each one before running it.

Loading voting…