PocketMine-MP ResourcePackDataInfoPacket amplification vulnerability due to lack of resource pack sequence status checking
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 5.32.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pocketmine/pocketmine-mp
- Affected
- < 5.32.1
- Fixed in
- 5.32.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqqv-56h5-f57g lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.32.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A denial-of-service / out-of-memory vulnerability exists in the STATUSSENDPACKS handling of ResourcePackClientResponsePacket. PocketMine-MP processes the packIds array without verifying that all entries are unique. A malicious (non-standard) Bedrock client can send multiple duplicate valid pack UUIDs in the same STATUSSENDPACKS packet, causing the server to send the same pack multiple times. This can quickly exhaust memory and crash the server. Severity: High — Remote DoS from an authenticated client. --- Details Relevant code (simplified): Root cause: The packIds array is taken directly from the client packet and processed as-is. There is no check to ensure that all requested packs are unique. A malicious client can craft a STATUSSENDPACKS packet with many duplicates of a valid UUID. Each duplicate results in the server re-sending the same pack, consuming additional memory. Why this is unexpected: Mojang's official clients never send duplicates in packIds. PocketMine assumes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fqqv-56h5-f57g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fqqv-56h5-f57g Advisory: PocketMine-MP `ResourcePackDataInfoPacket` amplification vulnerability due to lack of resource pack sequence status checking IDs: GHSA-fqqv-56h5-f57g Record: https://patchnext.com/advisories/ghsa-fqqv-56h5-f57g (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 5.32.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pocketmine/pocketmine-mp: affected < 5.32.1; fixed in 5.32.1 ## Suggested inspection (read-only) - Packagist pocketmine/pocketmine-mp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pocketmine/pocketmine-mp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fqqv-56h5-f57g (GitHub-reviewed advisory GHSA-fqqv-56h5-f57g lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.32.1) Commands are suggestions: review each one before running it.
Loading voting…