paillier-zk has ambiguous challenge derivation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (paillier-zk 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io paillier-zk
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpr5-jp2j-4q2f lists affected ranges: crates.io paillier-zk >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Challenge derivation in non-interactive ZK proofs was ambiguous and that could lead to security vulnerability (however, it's unknown if it could be exploited).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpr5-jp2j-4q2f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fpr5-jp2j-4q2f Advisory: paillier-zk has ambiguous challenge derivation IDs: GHSA-fpr5-jp2j-4q2f Record: https://patchnext.com/advisories/ghsa-fpr5-jp2j-4q2f (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: paillier-zk 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io paillier-zk: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - crates.io paillier-zk: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on paillier-zk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpr5-jp2j-4q2f (GitHub-reviewed advisory GHSA-fpr5-jp2j-4q2f lists affected ranges: crates.io paillier-zk >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…