stigmem-node: Auth-disabled deployments may grant broad anonymous access outside loopback
CVE-2026-76243GHSA-fp6w-8wpg-74g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (stigmem-node 0.9.0a2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI stigmem-node
- Affected
- < 0.9.0a2
- Fixed in
- 0.9.0a2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fp6w-8wpg-74g5 lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fp6w-8wpg-74g5 lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-76243: 0.56% estimated exploitation activity in the next 30 days; percentile 46.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Stigmem nodes configured with authentication disabled could grant the anonymous identity broad read/write/federation capabilities if exposed outside a loopback-only local development environment. Impacted users are operators who intentionally disabled authentication while binding the node to a non-loopback URL. Patches Patched in 0.9.0a2. The node now refuses unauthenticated operation outside loopback-only local development. Workarounds Before upgrading, keep authentication enabled for all non-local deployments and do not expose nodes with authentication disabled to untrusted networks. Upgrade Upgrade to the patched release: If developers install through the Stigmem meta-package instead, they should use the matching extra for their deployments, for example: Resources - Release: https://github.com/eidetic-labs/stigmem/releases/tag/v0.9.0a2 - Changelog: https://github.com/eidetic-labs/stigmem/blob/v0.9.0a2/CHANGELOG.md#L14-L35 - Security policy and posture:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-fp6w-8wpg-74g5
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-fp6w-8wpg-74g5
- Revision 1 · created ·
Published from ghsa record GHSA-fp6w-8wpg-74g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-76243 Advisory: stigmem-node: Auth-disabled deployments may grant broad anonymous access outside loopback IDs: CVE-2026-76243, GHSA-fp6w-8wpg-74g5 Record: https://patchnext.com/advisories/ghsa-fp6w-8wpg-74g5 (revision 4, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: stigmem-node 0.9.0a2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI stigmem-node: affected < 0.9.0a2; fixed in 0.9.0a2 ## Suggested inspection (read-only) - `python -m pip show stigmem-node`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on stigmem-node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fp6w-8wpg-74g5 (GitHub-reviewed advisory GHSA-fp6w-8wpg-74g5 lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2) - Verified: https://osv.dev/vulnerability/GHSA-fp6w-8wpg-74g5 (OSV record GHSA-fp6w-8wpg-74g5 lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…