React Server Components are Vulnerable to RCE
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitejs/plugin-rsc 0.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.5.2
- Fixed in
- 0.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmh4-wr37-44fp lists affected ranges: npm @vitejs/plugin-rsc >=0 <=0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fmh4-wr37-44fp lists affected ranges: npm @vitejs/plugin-rsc >=0 <0.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary @vitejs/plugin-rsc vendors react-server-dom-webpack, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r Impact Applications using affected versions of @vitejs/plugin-rsc are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability. Recommendations Upgrade immediately to @vitejs/plugin-rsc@0.5.3 or later. Workarounds Applications not using server-side React or React Server Components are unaffected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fmh4-wr37-44fp
- Revision 2 · amended ·
Amended from osv record GHSA-fmh4-wr37-44fp
- Revision 1 · created ·
Published from ghsa record GHSA-fmh4-wr37-44fp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fmh4-wr37-44fp Advisory: React Server Components are Vulnerable to RCE IDs: GHSA-fmh4-wr37-44fp Record: https://patchnext.com/advisories/ghsa-fmh4-wr37-44fp (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vitejs/plugin-rsc 0.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vitejs/plugin-rsc: affected <= 0.5.2; fixed in 0.5.3 ## Suggested inspection (read-only) - `npm ls @vitejs/plugin-rsc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vitejs/plugin-rsc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fmh4-wr37-44fp (GitHub-reviewed advisory GHSA-fmh4-wr37-44fp lists affected ranges: npm @vitejs/plugin-rsc >=0 <=0.5.2) - Verified: https://osv.dev/vulnerability/GHSA-fmh4-wr37-44fp (OSV record GHSA-fmh4-wr37-44fp lists affected ranges: npm @vitejs/plugin-rsc >=0 <0.5.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…