@saltcorn/plugins-loader unsanitized plugin name leads to a remote code execution (RCE) vulnerability when creating plugins using git source
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@saltcorn/plugins-loader 1.0.0-beta.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.0.0-beta.13
- Fixed in
- 1.0.0-beta.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fm76-w8jw-xf8m lists affected ranges: npm @saltcorn/plugins-loader >=0 <1.0.0-beta.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm76-w8jw-xf8m lists affected ranges: npm @saltcorn/plugins-loader >=0 <=1.0.0-beta.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary When creating a new plugin using the git source, the user-controlled value req.body.name is used to build the plugin directory where the location will be cloned. The API used to execute the git clone command with the user-controlled data is childprocess.execSync. Since the user-controlled data is not validated, a user with admin permission can add escaping characters and execute arbitrary commands, leading to a command injection vulnerability. Details Relevant code from source (req.body) to sink (childprocess.execSync). - file: https://github.com/saltcorn/saltcorn/blob/v1.0.0-beta.13/packages/server/routes/plugins.js#L1400 - file: https://github.com/saltcorn/saltcorn/blob/v1.0.0-beta.13/packages/saltcorn-data/models/plugin.ts#L44 - file: https://github.com/saltcorn/saltcorn/blob/v1.0.0-beta.13/packages/server/loadplugins.js#L64-L65 - file: https://github.com/saltcorn/saltcorn/blob/v1.0.0-beta.13/packages/plugins-loader/plugininstaller.js#L41-L61 - file:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fm76-w8jw-xf8m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fm76-w8jw-xf8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fm76-w8jw-xf8m Advisory: @saltcorn/plugins-loader unsanitized plugin name leads to a remote code execution (RCE) vulnerability when creating plugins using git source IDs: GHSA-fm76-w8jw-xf8m Record: https://patchnext.com/advisories/ghsa-fm76-w8jw-xf8m (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @saltcorn/plugins-loader 1.0.0-beta.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @saltcorn/plugins-loader: affected <= 1.0.0-beta.13; fixed in 1.0.0-beta.14 ## Suggested inspection (read-only) - `npm ls @saltcorn/plugins-loader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @saltcorn/plugins-loader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fm76-w8jw-xf8m (OSV record GHSA-fm76-w8jw-xf8m lists affected ranges: npm @saltcorn/plugins-loader >=0 <1.0.0-beta.14 (fixed)) - Verified: https://github.com/advisories/GHSA-fm76-w8jw-xf8m (GitHub-reviewed advisory GHSA-fm76-w8jw-xf8m lists affected ranges: npm @saltcorn/plugins-loader >=0 <=1.0.0-beta.13) Commands are suggestions: review each one before running it.
Loading voting…