Skip to content

← Actionable
High, CVSS 8.3amended

Winter: ImportExportController AJAX handlers bypass granular import/export permission gate

GHSA-fm29-4mq3-phg6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Affected versions of Winter CMS did not enforce the ImportExportController behavior's granular access control on the handlers that actually perform the work. The behavior supports per-operation access control through the import[permissions] and export[permissions] configuration keys, enforced by userHasAccess(). That check was applied only to the import() and export() page actions. Backend\Classes\Controller::execAjaxHandlers() dispatches AJAX handlers and returns before execPageAction() runs, and the behavior binds its import and export form widgets in its constructor on every request to the controller. The handlers were therefore fully functional without the gated page action ever executing, and none of them carried the check: - onImport() — reaches $model-import() with attacker-supplied column mappings - onImportLoadForm() - onImportLoadColumnSampleForm() - onExport() — reaches $model-export() - onExportLoadForm() - download() — streams a completed export file An…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fm29-4mq3-phg6

  2. Revision 1 · created ·

    Published from osv record GHSA-fm29-4mq3-phg6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-fm29-4mq3-phg6

Advisory: Winter: ImportExportController AJAX handlers bypass granular import/export permission gate
IDs: GHSA-fm29-4mq3-phg6
Record: https://patchnext.com/advisories/ghsa-fm29-4mq3-phg6 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-backend-module: affected <= 1.2.13; fixed in 1.2.14

## Suggested inspection (read-only)
- Packagist winter/wn-backend-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-backend-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fm29-4mq3-phg6 (OSV record GHSA-fm29-4mq3-phg6 lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-fm29-4mq3-phg6 (GitHub-reviewed advisory GHSA-fm29-4mq3-phg6 lists affected ranges: Packagist winter/wn-backend-module >=0 <=1.2.13)

Commands are suggestions: review each one before running it.

Loading voting…