Skip to content

← Actionable
High, CVSS 8.1amended

GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary command execution

CVE-2026-110858GHSA-f9j4-qggq-h239

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gitpython

    Affected
    >= 3.1.30, < 3.2.0
    Fixed in
    3.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-110858: 0.46% estimated exploitation activity in the next 30 days; percentile 40.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `Remote.pull()` in GitPython forwards its positional `refspec` argument directly to the `git pull` child process while its unsafe-option guard inspects only keyword arguments. An application that passes attacker-influenced data as the `refspec` (for example a user-supplied branch or refspec parameter in a web or CI service) can supply an option-shaped value such as `--upload-pack= `. The value bypasses the `unsafe_git_pull_options` check, is placed after the `--` separator on the `git pull` command line, and is executed as the upload-pack program for local-path or SSH transports. This yields arbitrary command execution with the privileges of the calling process using the documented default arguments (`allow_unsafe_options=False`).

Root Cause `Remote.pull()` is documented to reject dangerous options unless `allow_unsafe_options=True`, and `--upload-pack` is explicitly listed as such an option. The guard, however, only screens keyword arguments and never the positional…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-f9j4-qggq-h239

  2. Revision 1 · created ·

    Published from ghsa record GHSA-f9j4-qggq-h239

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110858

Advisory: GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary command execution
IDs: CVE-2026-110858, GHSA-f9j4-qggq-h239
Record: https://patchnext.com/advisories/ghsa-f9j4-qggq-h239 (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected >= 3.1.30, < 3.2.0; fixed in 3.2.0

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f9j4-qggq-h239 (GitHub-reviewed advisory GHSA-f9j4-qggq-h239 lists affected ranges: PyPI gitpython >=3.1.30 <3.2.0)
- Verified: https://osv.dev/vulnerability/GHSA-f9j4-qggq-h239 (OSV record GHSA-f9j4-qggq-h239 lists affected ranges: PyPI gitpython >=3.1.30 <3.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…