sp1-recursion-gnark-ffi has insufficient range checks of BabyBear arithmetic
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sp1-recursion-gnark-ffi 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io sp1-recursion-gnark-ffi
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f77q-r5qm-w4m8 lists affected ranges: crates.io sp1-recursion-gnark-ffi >=0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The Gnark recursion circuit constrains arithmetic over BabyBear when the native field of the ZKP circuit is the BN254 scalar field. Proper implementation of this logic requires range checking Bn254 values to be less than the BabyBear modulus. In versions < 1.2.0, functions like InvF and InvE used values generated by hints that were not appropriately range checked. These issues are resolved in versions 1.2.0 and higher, by adding range checks in the appropriate places. This code was covered under the original audit scope of the recursion circuit audit by Veridise, and both Veridise and Kalos revisited the code for similar issues and found no additional vulnerabilities. This issue was discovered by the Succinct team on September 3rd. The issue was fixed and resolved within 48 hours, and released with V1.2.0 (note that a later V2.0.0 release has the same contents as V1.2.0 to respect semver), with production SP1 users being notified and upgraded immediately. The V1.1.0 verifier was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f77q-r5qm-w4m8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-f77q-r5qm-w4m8 Advisory: sp1-recursion-gnark-ffi has insufficient range checks of BabyBear arithmetic IDs: GHSA-f77q-r5qm-w4m8 Record: https://patchnext.com/advisories/ghsa-f77q-r5qm-w4m8 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sp1-recursion-gnark-ffi 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io sp1-recursion-gnark-ffi: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - crates.io sp1-recursion-gnark-ffi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sp1-recursion-gnark-ffi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f77q-r5qm-w4m8 (GitHub-reviewed advisory GHSA-f77q-r5qm-w4m8 lists affected ranges: crates.io sp1-recursion-gnark-ffi >=0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…